Jump to content
  • 0

I can't get the Duplo Toolo Remote Control Dozer 2949 to work

The Hud


I got the Duplo Toolo RC Dozer 2949 in a lot I bought from eBay, but it unfortunately didn't come with any instructions. I put in fresh batteries, but I can't get it to work. Do I need to sync the controller with the base?

 Any help would be appreciated. This looks like a lot of fun if I can get it to work.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
52 minutes ago, kaczy said:

Maybe that will help http://bricks.rupprecht.me/?p=2353

Thank you very much! I was very hopeful, since there doesn't appear to be any special trick according to those instructions that you provided, but still no luck.

I also cleaned the battery terminals in the remote control and the car, but still no luck. :(

I might just have a defective unit.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...